This topic contains 3 replies, has 2 voices, and was last updated by  Wade 1 month ago.

Local install of Iguana on macOS is extremely sluggish

  • I’ve installed the trial version of Iguana and run into an issue. I can access Iguana in a browser (at http://localhost:25000/, for instance) but it is extremely slow to load and my browser hangs for 10-30 seconds when navigating to a new page.

    Chrome shows a ‘Waiting on localhost…’ status during the delay. Some quick Google searching shows this is a common accessing localhost websites but I’ve tried every solution I can find with no luck.

    Other details:
    OS: macOS 10.12.5
    Iguana: 6.0.6

    Troubleshooting tried so far:
    Tried Chrome, Safari, and Firefox
    Confirmed ::1 localhost is in hosts file
    Changed Iguana web server port (twice)
    Turned off DNS prefetching in Chrome
    Had a colleague access my instance of Iguana from another computer (still sluggish but could access it)
    Restarted multiple times

    Any ideas? I’m guessing this may not be an issue with Iguana itself but hoping someone has encountered this before.

    Thanks!

    If your machine’s hostname has a .local suffix could you try removing it?

    In your terminal just run the command hostname to see what it’s currently set to and then sudo hostname -s {newname}

    That did it! Thanks so much!

    Do you know why that works and what exactly was going wrong when the .local was set (mostly for my curiosity)?

    Glad that worked for you!

    To be honest I’m not sure why the .local suffix seems to cause trouble under some circumstances, but I’ve had success with removing it in the past.

    It’s definitely something I’ll need to look into further so we can determine if there’s a better solution that doesn’t involve modifying hostnames.

You must be logged in to reply to this topic.