This topic contains 4 replies, has 2 voices, and was last updated by  lev 2 years, 11 months ago.

vmd changes not being saved

  • I have edited my HL7_2.5.1.vmd file several time to add the Catchall() Message Definition. The adding of the Catchall() saves just fine but no matter how I try to apply it as the Default (unidentified message) it will not save that setting. I will make the change, click apply/ok/save, and then open that same vmd file back up and the Default (unidentified message) will be set back to None.

    > Can anyone recreate this issue? Are there steps I am missing?

    Thanks for the help and support from this community!

    Chameleon v5.6 b12
    winbuildp5/2014-10-31_11-46-51.build_Iguana_5_6_12@9_32

    I have found that this might be specific to me trying to add the catchall() to the HL7_2.5.1.vmd as I was able to edit a different vmd file and save those changes. Is there a reason I can’t edit the original HL7_2.5.1.vmd even if I rename it something like HL7_2.5.1_catchall.vmd ?

    The Library vmd files exist to contain HL7 Standard content in Chameleon readable form. The ‘catch_all’ Message Definition is not part of HL7 Standard. One should never modify the Library vmd files (the vmd files in ../Library folder). It jeopardises product integrity. For any custom need, always create your own copy of needed vmd file and use the copy.

    and that is what I tried to do by creating the HL7_2.5.1_catchall.vmd but it still wont save the catchall() unknown message catch option in my custon vmd.

    Chris, this question sounds more like Support ticket. Support questions can be emailed to support@interfaceware.com.

You must be logged in to reply to this topic.