Install or upgrade Fleet Manager

Install Fleet Manager

Because Fleet Manager is part of the Iguana Enterprise package, you will need to contact support at support@interfaceware.com to get a copy of the installer.

Note: Please contact your account manager or visit our Iguana Packages page for more information about the Iguana Enterprise package.

Windows

  1. Use an account with Local Administrator privileges.
  2. Contact support at support@interfaceware.com to get the Fleet Manager installer.
  3. If you are upgrading it is best to stop the Fleet Manager service.

    Note: The installer will attempt to stop the service but it can time out and cause the upgrade to fail. If this occurs simply stop the service and run the installer again.

  4. Run the installer and accept the defaults.
  5. Run Fleet Manager by using a web browser to connect to http://localhost:9191.
  6. Login to Fleet Manager using the defaults, user = admin and password = password.

Linux and Mac

  1. Contact support at support@interfaceware.com to get the Fleet Manager installer.
  2. Create a service user with administrator rights, we recommend fleetmanager (but you can use any name).

    Note: You can use any user with administrator rights but we strongly recommend using a dedicated user for running a daemon — particularly on a production server.

    If you use a personal logon it may be disabled or have permission changes in the future.

  3. Open a terminal window.
  4. Unpack the installer tarball file, for example monitor_installer_2_1_35_osx.tgz or monitor_installer_2_1_37_linux.tgz:
    1. You can unpack by double clicking on the tarball in the Finder (Mac) or in the Files app (Linux).
    2. Alternatively you can use terminal and change to the download directory and use tar to unpack:
      cd <download directory>
      tar -xvzf <downloaded install file name>.tgz

      For example:

      cd /Users/julianmuir/downloads
      tar -xvzf monitor_installer_2_1_37_osx.tgz
  5. If you are upgrading it is best best to stop the Fleet Manager daemon.

    Note: The installer will attempt to stop the daemon but it can time out and cause the upgrade to fail. If this occurs simply stop the daemon and run the installer again.

  6. Change directory to download directory and run the installer:
    cd <downloads directory>
    monitor_installer_<version> --run

    For example:

    cd /Users/julianmuir/downloads 
    monitor_installer_2_1_37 --run
  7. Choose the user to run the daemon, for example fleetmanager (see step 2 above).

    You should use a dedicated daemon user for production servers (see step 2 above). However for testing you can safely use a personal logon.

  8. Choose the install directory.

    The install directory will default to the home directory of the user chosen in the previous step — but you can choose to install in any directory. Your system administrator may prefer a different location particularly for production servers.

  9. The installer will look something like this:
    Note: As this was only a test server I used my personal logon.
    fleet manager installer
  10. Run Fleet Manager by using a web browser to connect to http://localhost:9191.
  11. Login to Fleet Manager using the defaults, user = admin and password = password.

Please contact support at support@interfaceware.com if you need further assistance with installing Fleet Manager

Upgrade Fleet Manager [top]

To upgrade Fleet Manager simply install the new version by following the install instructions above — there are no extra steps required.

The installer will do the following:

  • Detect and unregister the existing service/daemon if it exists
  • Install the new version of Fleet Manager into a new versioned directory
  • Detect and use the existing PostgresSQL database
  • Create and start the new daemon/service

Note: Fleet Manager is always installed into a versioned directory. When you upgrade the old install directory is not deleted — this means it is possible to downgrade easily if there is a problem.

You can delete the (versioned) install directory for the previous version — it is recommended best practice to wait until you are confident the new version is working correctly.

Leave A Comment?