This topic contains 3 replies, has 2 voices, and was last updated by  gbruer 7 years, 12 months ago.

Translator Annotations never loads

  • One of our To Translator channels works we use it on another server, but when we go to edit the script, the annotations take forever to load, or they never load. Usually we have the annotations disabled because we know it has this problem, but occasionally the annotations start and the page stop responding, and when we try to go back to the editor, it never/hardly ever loads.

    Is there a javascript function we could try to run to disable annotations so we can stop the annotations when the Stop Annotations button hasn’t loaded yet?

    Do you know how we could fix this or what could cause this? The script just connects to a database and maps HL7 messages to a database table and then calls the DB:merge function, but I know it’s not a database connection issue because I’ve commented those lines out and it still doesn’t work right.

    There is function iguana.isTest(). It returns true if script is open in Editor.
    Every function that has ‘live’ parameter – change it, instead of live=true, or live=false change it to be live = Live.

    Add if statement in very beginning:
    if iguana.isTest() then Live = false end

    Then all functions using ‘live’ will simulate activity instead of actually connecting to your database and modify it or so …
    Check in online KB about iguana.isTest()

    Thanks, that’s a great idea! I though we were already using that, but we weren’t for this project. I’ll try that as soon as it lets me edit the translator script.

    The problem was the database connection, because our test server doesn’t have that database on it. I set it up to use a SQLITE database if it’s in the editor and on that server.

    For future people, logging out and logging back in worked for me to get the editor back to annotations disabled mode. (What didn’t work was exiting the translator while remaining logged in, using a different computer that was already logged in, and pressing and clicking randomly on the loading screen.:)

You must be logged in to reply to this topic.